Zenky.io
Search…
Публикация приложения
Счетчики и пиксели
Промо материалы
Установка модуля обмена Битрикс для 1С
Для 1С: Управление торговлей ред. 11.4. релиз 11.4.8.73

Порядок установки модуля

Если раньше был установлен модуль обмена 4 версии, то необходимо обновить его до последней версии, а только потом устанавливать модуль обмена 5 версии
Если раньше стояла 4 версия модуля, то после обновления модуля до 5 версии – необходимо запустить внешнюю обработку, которая сконвертирует настройки обмена до 5 версии. Обработка находится там же, где и сам модуль обмена.
0. Выйти из всех 1С, подключенных рабочей базе, чтобы не было конфликтов и модуль установился без проблем.
1. Установить скачанный установщик модуля обмена для 1С: УТ, 11.4 — Версия модуля 7.0.1.27 (скачать). Или просто скачать распакованный файл конфигурации 1Cv9.cf. Если у вас другая версия 1С, то выбрать соответствующий модуль из таблицы соответствия.
2. Запустить систему 1С:Предприятие в режиме "Конфигуратор".
3. Сделать архивную копию информационной базы. Для этого в меню "Администрирование" выбрать пункт "Выгрузка информационной базы" и в открывшемся диалоге указать имя файла, в который будут записаны данные.
4. Открыть конфигурацию, для этого в меню "Конфигурация" выбрать пункт "Открыть конфигурацию" или нажать на соответствующую кнопку.
5. Если конфигурация закрыта для изменения(на скриншоте в дереве конфигурации соответствующий значок), то необходимо включить возможность изменения.
6. Для того, чтобы включить возможность изменения объектов конфигурации, необходимо в меню "Конфигурация" выбрать "Поддержка", затем "Настройка поддержки". В открывшемся окне нажать кнопку "Включить возможность изменения". В окне "Настройка правил поддержки" выбрать дважды "Объект поставщика редактируется с сохранением поддержки", нажать "ОК". Сохранить конфигурацию.
7. После выполнения операции в конфигурацию 1С можно вносить изменения. Значок в дереве конфигурации оповещает об этом. После нажатия «Закрыть» система может тормозить и подвиснуть на несколько секунд или минут, следует терпеливо подождать :)
8. Вызвать режим "Сравнить, объединить с конфигурацией из файла" из меню "Конфигурация". В этом режиме будут показаны только различающиеся объекты дополнения и используемой конфигурации, поэтому полностью идентичные объекты могут отсутствовать в окне сравнения-объединения.
9. В диалоге выбора указать файл конфигурации «XXX.cf». Который вы предварительно скачали. Скачать файл конфигурации 1Cv8.cf.
Если вы распаковывали модуль через setup.exe то, по умолчанию он лежит по следующему адресу: C:\Users\...\AppData\Roaming\1C\1Cv82\tmplts\1С-Битрикс\ ОбменСБ24\(конфигурация 1С).
10. В окне сравнения объединения необходимо исключить из объединения все объекты. Для этого можно снять флаг напротив названия конфигурации.
11. Для указания объектов только устанавливаемого модуля, необходимо нажать на кнопку "Действия" – "Отметить по подсистемам файла".
12. Нужно установить флажок напротив пункта «Битрикс»
13. Также необходимо включить подсистему «Битрикс»: "Конфигурация" - "Общие" – "Подсистемы" – "Битрикс". Если модуль ранее уже стоял, то этот пункт выполнять не нужно.
14. Для выполнения объединения необходимо нажать на кнопку «Выполнить».
15. В некоторых случаях может возникнуть окно «Неразрешимые ссылки». В этом случае нужно нажать на кнопку «Продолжить»
16. После выполнения объединения конфигурации сохраняем конфигурацию и обновляем базу данных. Обновить базу данных можно нажав на кнопку указанную на скриншоте.
17. Если модуль раньше не был установлен, то высветится окно с изменениями в структуре. Нужно нажать на кнопку «Принять».
18. После установки модуля, для работы с ним, пользователям необходимо добавить роль «Роль по работе с БУС».
Выбрать нужного пользователя и кликнуть на иконку редактирования
В открывшемся окне, перейти на вкладку «Прочие»
В открывшемся списке ролей домотать до самого низа и выделить галочкой «Роль по работе БУС»
19. Ура! модуль обмена Битрикс установлен!

Печать чеков по данным с сайта

ТОЛЬКО ДЛЯ РОССИЙСКИХ КОНФИГУРАЦИЙ
Если необходим функционал печати чеков по данным с сайта, то необходимо доработать объект типовой конфигурации «Модуль управляемого приложения».
1. В режиме конфигуратора развернуть дерево конфигурации
2. Выбрать узел «Управление торговлей», нажать на правую кнопку мыши и выбрать пункт «Открыть модуль управляемого приложения».
3. Находим процедуру «ПриНачалеРаботыСистемы()»
Если конфигурация 1С – УТ, ERP 2 или КА 2, то добавляем в конец 3 строки:
Если Б_ПечатьЧековСервер.ЭтоНужноеРабочееМесто() тогда ПодключитьОбработчикОжидания("БитриксПроверкаЧеков", 300); КонецЕсли;
Если модуль УНФ , то добавляем в конец 1 строку
ПодключитьОбработчикОжидания("БитриксПроверкаЧеков", 300);
4. Добавляем процедуру «БитриксПроверкаЧеков()»
Процедура БитриксПроверкаЧеков() Экспорт лКоличествоДоков = Б_ПечатьЧековСервер.КоличествоДокументовДляЧеков(); Если лКоличествоДоков > 0 тогда Б_ПечатьЧековКлиент.ПечатьЧеков(); КонецЕсли; КонецПроцедуры
При обновлении конфигураций 1С нужно следить, чтобы обновление 1С не затерло это изменение.